• Most new users don't bother reading our rules. Here's the one that is ignored almost immediately upon signup: DO NOT ASK FOR FANEDIT LINKS PUBLICLY. First, read the FAQ. Seriously. What you want is there. You can also send a message to the editor. If that doesn't work THEN post in the Trade & Request forum. Anywhere else and it will be deleted and an infraction will be issued.
  • If this is your first time here please read our FAQ and Rules pages. They have some useful information that will get us all off on the right foot. More details on our policies, especially our Own the Source rule are available here. If you do not understand any of these rules send a private message to one of our staff for further details.
  • Fan Edit Of The Year (FEOTY) 2021: and the WINNERS are...! here Congratulations!

Boon's guide to fanediting with Sony Vegas

Bobgarcia74

Well-known member
Messages
307
Reaction score
0
Trophy Points
21
shifuuu.jpg


Or what the guy up there said :lol:
 

dangermouse

Well-known member
Faneditor
Messages
1,100
Reaction score
2
Trophy Points
48
I'm stuck on step 1 - creating the file! The lagarith file I get is, firstly, without sound, and, secondly, the picture is slightly stretched vertically (i.e. virtualdub is not keeping the same aspect ratio, despite "no change" being ticked all over the place).
For the sound processing I'm using the ac3 filter from fccHandler.
Any help would be appreciated! :)
 

ThrowgnCpr

awol
Staff member
Messages
15,087
Reaction score
28
Trophy Points
133
Yes, the picture will look stretched upon playback (but nothing is wrong!!). Virtualdub is not changing the dimensions (unless you added a resize filter). For anamorphic widescreen (NTSC), your DVD stores the video at 720x480 pixels, but upon playback stretches it to 853x480. The lagarith video will also be 720x480, however it doesn't store the PAR (pixel aspect ratio) information. You have to tell your media player (VLC, media player classic) or video editing software that it is indeed widescreen (in Vegas, you can right click on the media in the timeline to get the properties.

A heads up, the lagarith video does not store field information either. You have to correctly set this also. whether or not it is progressive or interlaced, and if interlaced if its top or bottom field first. All these options are in the media properties in Vegas like I described above.


For the audio, boon, myself and others convert the AC3 audio to WAV to add separately to Vegas. If the track is 5.1, you can use BeSweet or another program to separate to 6 WAV files.
 

theslime

Well-known member
Messages
1,234
Reaction score
1
Trophy Points
41
What Throw said.

For a slightly different way to get the same result, you can try my Avisynth guide, points 1 through 4.

For point 3, use this shorter script instead of the one in the guide:
Code:
video=MPEG2Source("PATH\film.d2v", cpu=0)
audio=Nicac3Source("PATH\film.ac3")
AudioDub(video,audio)
It avoids PGDemux, but uses DGIndex instead. I prefer this way, but the result is the same.
 
S

steFANedit

I'm making a fanedit (rob zombie's HALLOWEEN) following this guide here. but I have a problem though. after rendering the project and upon viewing it, every cut(not just what I have cut but the original editing) have a 1-frame-fade-to-the-next to it.

Example: a scene that plays out exactly as it originally did (I have done no editing to it), 2 people talking. camera on person 1 cut to person 2. Now when we have the cut to person 2 there is a 1 frame fade from the footage of person 1 over the footage of person 2. The original source has nothing like this. anyone that have any idea what I'm talking about and what I'm doing wrong?
 
S

steFANedit

okay so I found out what I did wrong. rendering a video with framerate 23.976 to 29.970 isn't that good of an idea :b
 

reave

Well-known member
Staff member
Messages
4,339
Reaction score
51
Trophy Points
53
bumpityfinishthisboonprettyplease
 

AEmovieguy

Well-known member
Faneditor
Messages
256
Reaction score
0
Trophy Points
26
steFANedit said:
okay so I found out what I did wrong. rendering a video with framerate 23.976 to 29.970 isn't that good of an idea :b

If you're ever using footage from sources of varying framerates and/or need to render your project in a framerate that does not match that of the source files and/or project properties, Sony Vegas has an option to "Disable Resampling," which should eliminate any, what I would describe as, 'ghosting/haloing/trailing' effects during fast motion and transitions when working with differing framerate footage.

For any footage that does not match your project's framerate and/or your desired rendering framerate, right-click said footage in the timeline and enter the video stream's 'properties.' In the 'Video Event' tab, simply change the selection from 'Smart Resample' to 'Disable Resample.'

Only catch is, unless you completely edited your source video in the timeline and did this setting change to the whole feature before making any edits, you will have to do this setting change to each individual clip/edit on the timeline.

It'll be tedious, but I even do this for video footage that has the same framerate as my project properties and rendering settings (in these cases, mainly as a "just-in-case" or...placebo effect :tongue: ).

Good luck!
 
S

steFANedit

thanks AEmovieguy for the in-depth info. Sometimes (read; always) I just don't know what the hell I'm doing :?

Like for example: when I render the project that I'm was talking about above the output video file is darker than the source material. I looked around the world wide web :eek: ....and found nothing about it
.....
so I thought that maybe just up the brightness a little bit might be a nice way to sort of work around the problem.
But if I'm not mistaken the quality of the rendered video, now brightened a bit, becomes much worse (not so much, but noticeable, pixeled((is that a word?)) a bit.)

question: why does this happen? have anyone else encountered this problem? And: how do one go by to correct this darkening of avi files in vegas? (don't think my way is the way to go about this problem)
 

ThrowgnCpr

awol
Staff member
Messages
15,087
Reaction score
28
Trophy Points
133
it could be the switching of colorspace from YUV to RGB. What type of AVI are you editing? How did you create it? and what are you rendering with? FYI, you cannot to my knowledge edit in YUV colorspace in Vegas.
 
S

steFANedit

ThrowgnCpr said:
it could be the switching of colorspace from YUV to RGB. What type of AVI are you editing? How did you create it? and what are you rendering with? FYI, you cannot to my knowledge edit in YUV colorspace in Vegas.

okay so I used the guide that Boon created here but I also had to run the mpeg2 file throw DGPulldown

"1.1 if the video is interlaced, you may want to use a deinterlace filter. note that some NTSC interlacing comes from pulldown flags, so you may want to get rid of these by using dgpulldown"
......
so this I did. and what I'm working with in vegas is Lagarith lossless avi files (and I just checked that they are render as that with RGB by default, so this I must have)

when you say: switching of colorspace from YUV to RGB. how do I go about doing this?
I made a test in vegas doing the following: Color corrector, Computer RGB to Studio RGB... and it worked!! my god, it worked!!! I don't know if that what I should be doing but it sure looked like it did the trick. not sure why I even had to do this when the video files were RGB to begin with.

the rendering options are at the following:

MainConcept MPEG-2
DVD Architect NTSC Widescreen video stream

output type: DVD
fram rate: 23.976
I-frames: 15
B-frames: 2
Insert I-frames at markers: check
Field order: None (progressive scan)
Prioritize quality over size: check
Insert sequence header before every GOP
(then we have the usual bitrate, aspect ratio and video quality)
also: DC coeffiecient: 10bit (someone years ago on the fanedit CHAT told me to do this, can't remember why, so since then I have always made sure to have that specific settings on 10bit.)
 

Captain Khajiit

Well-known member
Donor
Messages
2,685
Reaction score
8
Trophy Points
48
steFANedit said:
I made a test in vegas doing the following: Color corrector, Computer RGB to Studio RGB... and it worked!! my god, it worked!!! I don't know if that what I should be doing but it sure looked like it did the trick. not sure why I even had to do this when the video files were RGB to begin with.

Studio RGB keeps to the 16-235 luma range used by TV and DVD. If you use computer RGB, then the range will be expanded to 0-255, which probably explains why your first encoding looked wrong. (Everything below 16 would look black, and everything above 235 would look white.). I would work in Studio RGB (or recompress the luma range back to 16-235 before encoding if you feel confident about doing this).

By the way, when you use full processing mode in Virtualdub, your AVI is automatically converted to RGB. When you select fast recompress, your AVI should stay in YUV, unless you have specified otherwise somewhere.
 
S

steFANedit

Captain Khajiit said:
By the way, when you use full processing mode in Virtualdub, your AVI is automatically converted to RGB. When you select fast recompress, your AVI should stay in YUV, unless you have specified otherwise somewhere.

That what's so strange, Virtualdub is set on full processing mode.
Remember that I had to add Color corrector, Computer RGB to Studio RGB ones in Vegas to get the output file at the same brightness as the source material. Well that worked but I had a quick look at the source material and it looks much better. It's like when I have added Computer RGB to Studio RGB the grain in the picture get more pixelstyle and without Computer RGB to Studio RGB well the output gets darker. I used Boons guide here to get the same output quality as the original source material was. But without another solution to this problem I don't think that's ever gonna happen.
 

TV's Frink

You Catch On Pretty Quick
Staff member
Donor
Faneditor
Messages
23,630
Reaction score
290
Trophy Points
193
rmania said:
Any idea when steps 4-9 will be posted. Thanks
boon isn't too active round these parts these days. I wouldn't count on it getting finished.
 

reave

Well-known member
Staff member
Messages
4,339
Reaction score
51
Trophy Points
53
Unless you keep saying it won't be finished. :D
 

Captain Khajiit

Well-known member
Donor
Messages
2,685
Reaction score
8
Trophy Points
48
steFANedit said:
That what's so strange, Virtualdub is set on full processing mode.

I wasn't advising you on what you should do. I was just telling you what the difference between Studio RGB and Computer RGB was and how Virtualdub behaves, in case you didn't know. :)

I think that full processing mode in Virtualdub compresses to RGB24 and Vegas uses RGB32. You might want to look at converting to RGB in Avisynth rather than in Virtualdub -- I would.

Converttorgb(matrix="rec601") #This converts to RGB32 expanding the luma range; the matrix line might be unnecessary.

I don't use Vegas, so I don't know which range it is best to work in, but I would imagine it is best to use the TV range and select StudioRGB. (If you do use the TV range, the colors will probably look inaccurate in the preview window, but they should be correct on your TV.)

If you want to keep the TV range:

Converttorgb(matrix="PC.601")

N.B. The following assumes that your source is DVD not HD.
 

TV's Frink

You Catch On Pretty Quick
Staff member
Donor
Faneditor
Messages
23,630
Reaction score
290
Trophy Points
193
reave said:
Unless you keep saying it won't be finished. :D
Oh, well in that case he will definitely not be finishing any fanedits. ;)
 
Top Bottom