If this is your first time here please read our FAQ and Rules pages. They have some useful information that will get us all off on the right foot. More details on our policies, especially our Own the Source rule are available here. If you do not understand any of these rules send a private message to one of our staff for further details.

Framerate issues with Handbrake/Vegas Pro 17
#1
Hi all,

I always have the same issue with fps being read in by Vegas Pro 17 as PAL 25 fps even though in handbrake I convert it to an H.264 mp4 with 23.98 fps. This always seems to leave me with two options in Vegas Pro, let the project be at 25 fps which seems like the incorrect framerate (and rendered clips have a slight stutter where it seems like frames freeze in place for split seconds) or I force the project to 23.98 fps and then the render seems to get the frame blending effect.

I assume something about my handbrake conversion is causing the issue but I select constant framerate and select 23.98.

Has anyone else that uses Handbrake and Vegas Pro 17 encountered a similar issue? Any ideas on resolution?

Edit: Some additional research I found out how to check detailed settings in mediainfo program. It is indeed variable framerate from 23.974 to 23.981. So this probably causes the import issue into vegas pro. I am going to experiment with something like ffpmeg but if anyone uses handbrake and doesn't have this problem I would still be happy to receive advice Smile

Thanks,
Adam
Reply
#2
Under the Handbrake Video tab, just below where you select Framerate, there is a tick box for Constant Framerate, or Variable Framerate. Have you ticked variable by mistake? Also never use Handbrake's automatic "same as source" framerate option. Tell it what framerate to use e.g 25fps, it's safer. Lastly under the Filters tab make sure you haven't got any interlacing options set.
[+] 3 users Like TM2YC's post
Reply
#3
(09-12-2020, 12:27 PM)TM2YC Wrote: Under the Handbrake Video tab, just below where you select Framerate, there is a tick box for Constant Framerate, or Variable Framerate. Have you ticked variable by mistake? Also never use Handbrake's automatic "same as source" framerate option. Tell it what framerate to use e.g 25fps, it's safer. Lastly under the Filters tab make sure you haven't got any interlacing options set.

Thank you for the reply!

I did indeed have constant framerate checked and 23.98 fps selected. Doing a bit of googling it seems like some other people report the same VFR even when doing so in handbrake. Could be something with my setup as I don't see it "widely" reported. I am learning to author the best command from ffmpeg but I'm actually very happy with the results so far! I might start using it instead of handbrake when fan editing is the goal Smile.

What do you mean when you say 25 fps is "safer"?
Reply
#4
(09-12-2020, 05:02 PM)amsunderman Wrote: What do you mean when you say 25 fps is "safer"?

I didn't word that very well, I just meant setting the correct framerate (whatever that may be) manually in Handbrake, is safer than letting the program do it automatically.
Reply
#5
Try turning off the stuff in the filters tab, in addition to what already been suggested.

[Image: Filters-3.png]
////////////////////////////////////////////////////////////////
// IdeasIdea Central //
////////////////////////////////////////////////////////////////
[+] 1 user Likes addiesin's post
Reply
#6
Is your original source 25fps, 23.976fps, or 29.97fps?
[+] 1 user Likes ChainsawAsh's post
Reply
#7
(09-13-2020, 01:07 AM)ChainsawAsh Wrote: Is your original source 25fps, 23.976fps, or 29.97fps?

This one according to mediainfo program was CFR 23.976. I ended up using Any Video Converter based on a recommendation elsewhere and it resolved the problem Smile
[+] 1 user Likes amsunderman's post
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)