If this is your first time here please read our FAQ and Rules pages. They have some useful information that will get us all off on the right foot. More details on our policies, especially our Own the Source rule are available here. If you do not understand any of these rules send a private message to one of our staff for further details.

Vegas movie studio importing .mp4 as green
#1
Vegas Movie Studio 17.0 Platinum.

I've created some credits videos - one from a .png, and another from a .png combined with source video, and both are working fine. The .pngs and the source video are 1920x800, and they render just fine, and output as lossless .mp4s which match the source perfectly. Their metadata in Windows Explorer reads correctly as 1920x800, they play in VLC perfectly as intended.

However, when I then import these .mp4 files back into Vegas to bookend my normal video cuts, it misreads their metadata as 1920x1080, skews and repeats the image, and renders them green.

https://ibb.co/cwxFRRL

What on Earth is happening, and how can I have Vegas read its own Vegas exports correctly?

Project properties: https://ibb.co/mys9WWD
Render properties: https://ibb.co/QmVzkpW
Reply
#2
When you drop something into Vegas a window pops up and it asks something like "do you want to match source settings?". Have you tried either letting it do this automatically, or doing the reverse, setting up the timeline settings yourself and then refusing to let it adjust the settings when you drop the new source in?

Also I notice a tick box in your render settings that reads "Allow source to adjust frame size". Have you tried unticking that?

You say " lossless .mp4s " but surely that's not correct. It's a lossy format. Are you saying that Vegas doesn't re-render the file?
Reply
#3
Easy fix is to click on the Event Pan/Crop in the event in the timeline, then until the xy lock icon and change the height to 800, then relock the xy lock. That will make the event match the 1080 x 800 you are looking for.

I'd recommend doing what TM2YC has pointed out too. I set all my projects to 1080 x 800 and then adjust my events to match.
Reply
#4
Thanks folks.

In the end it seems like an easier fix - I was replacing source media with an amended file, so effectively adding a new source file with the same name, and that seemed to have caused the source read offset. Ensuring I didn't just fix-and-replace media, instead ensuring updated versions had unique names, fixed the issue.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)