If this is your first time here please read our FAQ and Rules pages. They have some useful information that will get us all off on the right foot. More details on our policies, especially our Own the Source rule are available here. If you do not understand any of these rules send a private message to one of our staff for further details.

Blu Ray conversion
#1
I have using both ThrowgnCpr's and Gemini's guides for creating lossless video from Blu Ray and I have hit an impasse. 
I'm at the stage were I am trying to bring up the .m2v file in virtualdub using avisynth.  The m2v is on an external hard drive (L).  This is what wrote in the notepad.


Name the notepad All Files.avs. When I try to import it into Virtual Dub, I get this error message.



The way I see it, if I can't  extract a video that is just as the disc, whats the point of making a fanedit in the first place? I really want to resubmit my Avengers Assemble series and I can't get past this hurdle. If you can, please help.

Thanks

maxgremlin
Reply
#2
you can either install the mpeg-2 plugin (I think this one) or change from directshow to mpeg2source

mpeg2source("movie.d2v")
--------------------------: My Fanedits :--------------------------
Because You Were Home (the Strangers)

-------------------------: Consecutions :-------------------------
Reply
#3
I know its been almost a year since I posted but I finally have some time to fanedit.  I just recently ripped a blu ray using MakeMkv and I'm trying to open the mkv file in Virtual Dub.   After I make the script in notepad with avisynth:

DirectShowSource("G:\Ant Man\MARVEL'S_ANT-MAN_-_BLU-RAY_t00.mkv", fps=23.976) 

I get this error message when I try to open it in VirtualDub:




Any idea what I'm doing wrong here?

Thanks

Max
Reply
#4
make sure your codecs are up to date. Install the latest k-lite codec pack
--------------------------: My Fanedits :--------------------------
Because You Were Home (the Strangers)

-------------------------: Consecutions :-------------------------
Reply
#5
Thank you.....again....for you help.  Installing the codec pack was exactly what I needed to do. Once I did, I was able to load the mkv into VirtualDub no problem.

Unfortunately, I came across another problem.  I ripped a blu ray of the movie Ant Man and it came out just fine. But when I made an mkv of Dr Strange with MakeMKV the aspect ratio looked to be way off.  It was like the movie was encased in a black bar box.  I tried using MKVtoolNix to set the aspect ratio to 16:9 but got the same result.  It was my first time using MKVtoolNix so maybe I missed a setting.  

Any ideas?

Thank you.
Reply
#6
Okay. Correction on my part.  Nothing wrong with the MKV files. They both came out fine. Just turns out Antman is set to 1:85:1 aspect ratio while Dr Strange is set to 2:39:1 aspect ratio.

Still a problem of course. 

So now I am trying to resize using virtualDub.   I know 1:85:1 equals 37:20 aspect ratio in the resize filter. Wanted to know the equivalent for 2:39:1.  Also if anyone can point me to a good guide on resizing in virtualdub I would be grateful.
Reply
#7
(06-08-2017, 01:53 PM)maxgremlin Wrote: Okay. Correction on my part.  Nothing wrong with the MKV files. They both came out fine. Just turns out Antman is set to 1:85:1 aspect ratio while Dr Strange is set to 2:39:1 aspect ratio.

Still a problem of course. 

So now I am trying to resize using virtualDub.   I know 1:85:1 equals 37:20 aspect ratio in the resize filter. Wanted to know the equivalent for 2:39:1.  Also if anyone can point me to a good guide on resizing in virtualdub I would be grateful.

The resize filter just relies on your knowledge of basic math. If they are both 1080p files, the width on each would be 1920 pixels. Solve for the frame height using cross-multiplication:

https://www.mathsisfun.com/algebra/cross-multiply.html
--------------------------: My Fanedits :--------------------------
Because You Were Home (the Strangers)

-------------------------: Consecutions :-------------------------
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)